{ ifaces, hostname }: let pkgs = import {}; lib = pkgs.lib; ifacesL = lib.splitString "\n" ifaces; types = [ { name = "summary"; title = "Summary"; } { name = "hourly"; title = "Hourly"; } { name = "daily"; title = "Daily"; } { name = "monthly"; title = "Monthly"; } { name = "top10"; title = "Top 10"; } ]; in { html = '' ${hostname} - stats

${hostname}

${lib.concatMapStringsSep "\n" (iface: ''

${iface}

${lib.concatMapStrings (type: ''
${type.title}
'') types}
'') ifacesL}
''; }