ctucx.git: alpine-pkgs

My personal alpine-packages [deprecated in favor of nixos]

commit 0eae78b3ba24af35e201b6a904f6a7fcd38ad26c
parent d2695f4102a8c8dfc6fafae1b492afa823f062c6
Author: Leah (ctucx) <leah@ctu.cx>
Date: Wed, 20 Jan 2021 20:45:01 +0100

monitorix: add
3 files changed, 54 insertions(+), 0 deletions(-)
A
monitorix/APKBUILD
|
36
++++++++++++++++++++++++++++++++++++
A
monitorix/monitorix.confd
|
3
+++
A
monitorix/monitorix.initd
|
15
+++++++++++++++
diff --git a/monitorix/APKBUILD b/monitorix/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leah (ctucx) <leah@ctu.cx>
+# Maintainer: Leah (ctucx) <leah@ctu.cx>
+pkgname=monitorix
+pkgver=3.12.0
+pkgrel=8
+pkgdesc="Take control over your small server"
+url="https://www.monitorix.org/"
+arch="noarch"
+license="MIT"
+depends="rrdtool perl perl-cgi perl-rrd perl-config-general perl-config-simple perl-dbi perl-http-server-simple perl-libwww perl-mailtools perl-mime-lite perl-xml-simple"
+makedepends=""
+subpackages="${pkgname}-doc ${pkgname}-openrc"
+source="${pkgname}-${pkgver}.tar.gz::https://www.monitorix.org/monitorix-${pkgver}.tar.gz
+        ${pkgname}.initd
+	${pkgname}.confd"
+builddir="${srcdir}/${pkgname}-${pkgver}/"
+
+build() {
+	:
+}
+
+check() {
+	:
+}
+
+package() {
+	cd $builddir
+	make DESTDIR=${pkgdir} install-bin
+	make DESTDIR=${pkgdir} install-docs
+	install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+	install -Dm755 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="7cbdb27df1d84e87f0b99d310d3b3a7c27e369adc82c88e297966e36de82c2f800474447dd628041f2feb89817ee496cbae65a4b0e4942a2f75c900f16ccfcf1  monitorix-3.12.0.tar.gz
+4b27cf9c3e29934b38cd0503a5a570e9c1ec8c1fbdc9d2cd3392139a707ebade38eaad88c4a8e351575df6913c57f8b8323dd947beb80d76f7a0966138a41240  monitorix.initd
+66a9a59feabba067798d020fc4c913afc87c9493e7e7918180d26b6f60fb4615b9ae5d64a74317eaee1abcb8151e8f99a795f4cc86f7a6ee4afcb839b606a121  monitorix.confd"
diff --git a/monitorix/monitorix.confd b/monitorix/monitorix.confd
@@ -0,0 +1,3 @@
+# Here you can specify your Monitorix command line options.
+#
+OPTIONS=""
diff --git a/monitorix/monitorix.initd b/monitorix/monitorix.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+supervisor=supervise-daemon
+
+name="monitorix"
+description="Take control over your small server"
+
+command="/usr/bin/monitorix"
+command_user=root:root
+directory="/var/lib/$RC_SVCNAME"
+command_args="-c /etc/monitorix/monitorix.conf -p /run/monitorix.pid $OPTIONS"
+depend() {
+	need net localmount
+	after firewall
+}	
+