ctucx.git: alpine-pkgs

My personal alpine-packages [deprecated in favor of nixos]

commit 0fdf8e1251a4798a7603c2386f5620a950519c5c
parent ceda9d81a0fa1f5a545561d46f8a07fca3a2bf72
Author: Leah (ctucx) <leah@ctu.cx>
Date: Sun, 28 Feb 2021 15:18:55 +0100

update version, rename package
1 file changed, 6 insertions(+), 6 deletions(-)
M
ctucx-gallery/APKBUILD
|
12
++++++------
diff --git a/ctucx-gallery/APKBUILD b/ctucx-gallery/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Leah (ctucx) <leah@ctu.cx>
 # Maintainer: Leah (ctucx) <leah@ctu.cx>
-pkgname=gallery
+pkgname=ctucx-gallery
 pkgver=0.0.3
-pkgrel=4
+pkgrel=1
 pkgdesc="gallery-generator written in nimlang, used for photos.ctu.cx"
 url="https://cgit.ctu.cx/gallery"
 arch="all"

@@ -10,9 +10,9 @@ license="MIT"
 depends="imagemagick"
 makedepends="nim nimble"
 subpackages=""
-_commit="61683e35da184be1eed8d3a70eaf6e86ec58c941"
+_commit="720f8230846802d0e0f41afe6961f7c86aa35cd4"
 source="${pkgname}-${_commit}.tar.gz::https://cgit.ctu.cx/gallery/snapshot/gallery-${_commit}.tar.gz"
-builddir="${srcdir}/${pkgname}-${_commit}/"
+builddir="${srcdir}/gallery-${_commit}/"
 
 build() {
         cd ${builddir}

@@ -24,7 +24,7 @@ check() {
 }
 
 package() {
-        install -Dm755 ${builddir}/${pkgname} ${pkgdir}/usr/bin/ctucx-${pkgname}
+        install -Dm755 ${builddir}/gallery ${pkgdir}/usr/bin/ctucx-${pkgname}
 	install -Dm755 ${builddir}/sample.config ${pkgdir}/etc/ctucx-${pkgname}.conf
 }
-sha512sums="56188e0dd7ee94724684f5a871a4541b1c2333767c3704b06575b345ab7894acccca231e0dbbba6487bf267e931df43828610d575dd466409e40a2774262a58c  gallery-61683e35da184be1eed8d3a70eaf6e86ec58c941.tar.gz"
+sha512sums="305470abec3a5a18ae61dc5f2326cd23614ecf61642c81529631b4a0f0672da8878d93ad64d5612750b27688a39eeb272a3fa7c5820adb5eec76fe4e31797c5f  ctucx-gallery-720f8230846802d0e0f41afe6961f7c86aa35cd4.tar.gz"