ctucx.git: alpine-pkgs

My personal alpine-packages [deprecated in favor of nixos]

commit 22d017a189bf47ab6414cc71d0c7255494fac472
parent 9c262ba73d3e62438fbed999c58b3d6a34d951c0
Author: Leah (ctucx) <leah@ctu.cx>
Date: Thu, 21 Jan 2021 22:52:50 +0100

oeffi-web: update to new version
1 file changed, 5 insertions(+), 5 deletions(-)
M
oeffi-web/APKBUILD
|
10
+++++-----
diff --git a/oeffi-web/APKBUILD b/oeffi-web/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Leah (ctucx) <leah@ctu.cx>
 pkgname=oeffi-web
 pkgver=0.0.1
-pkgrel=17
+pkgrel=18
 pkgdesc="fast and simple tripplanner for the web"
 url="https://cgit.ctu.cx/oeffi-web"
 arch="all"

@@ -11,14 +11,14 @@ depends="openssl"
 makedepends="nim"
 install="$pkgname.pre-install"
 subpackages="${pkgname}-openrc"
-_commit="2d126b4077f63219c19dd50dc7e4e2a72826e666"
+_commit="5c5717745f2512a349c3926047312f662a0a6123"
 source="${pkgname}-${_commit}.tar.gz::https://cgit.ctu.cx/oeffi-web/snapshot/oeffi-web-${_commit}.tar.gz
         ${pkgname}.initd"
 builddir="${srcdir}/${pkgname}-${_commit}/"
 
 build() {
 	cd ${builddir}
-	nim c -d:release --nimcache:$PWD src/oeffi_nojs.nim
+	nim c -d:release --nimcache:$PWD src/oeffi.nim
 }
 
 check() {

@@ -26,12 +26,12 @@ check() {
 }
 
 package() {
-	install -Dm755 src/oeffi_nojs ${pkgdir}/usr/bin/${pkgname}
+	install -Dm755 src/oeffi ${pkgdir}/usr/bin/${pkgname}
 	install -Dm755 ${srcdir}/$pkgname.initd ${pkgdir}/etc/init.d/${pkgname}
 	mkdir -p ${pkgdir}/usr/share/oeffi-web
 	cp -r assets ${pkgdir}/usr/share/oeffi-web
 	cp -r templates ${pkgdir}/usr/share/oeffi-web
 }
 
-sha512sums="7139a0dc9f248c330f9cf3dde46dc2297ca68bbe7544c25d855f71bcaa736ab06b511b560ea2468c655ea16a4258c15ec2c53829727bf774319c7dac607d9678  oeffi-web-2d126b4077f63219c19dd50dc7e4e2a72826e666.tar.gz
+sha512sums="01e75e2e1413bfb6e8b6eac1eccda5d0a4d4ffe77899be4e98bc09ea36a15138796663238927c99eebd6fb12fe16831bc5fb11f4731e0fcf6cd6ea24890857fa  oeffi-web-5c5717745f2512a349c3926047312f662a0a6123.tar.gz
 a7c5f4509c3fcf52ff514604a42030fbab230db6ca7903e3f74b523331489dfa5401631952bb8705aa281e084bcd61f6cc5fc79b82bc422ebdc487901d44e426  oeffi-web.initd"