ctucx.git: alpine-pkgs

My personal alpine-packages [deprecated in favor of nixos]

commit b516765661c45b5d5eee000532861dd8a125edf4
parent 3aca38cbfa35f7ea014cb5066c8bc0c6dd118324
Author: Leah (ctucx) <leah@ctu.cx>
Date: Wed, 20 Jan 2021 20:44:08 +0100

oeffi-web: cleanup
1 file changed, 13 insertions(+), 12 deletions(-)
M
oeffi-web/APKBUILD
|
25
+++++++++++++------------
diff --git a/oeffi-web/APKBUILD b/oeffi-web/APKBUILD
@@ -1,8 +1,8 @@
-# Contributor:
-# Maintainer:
+# Contributor: Leah (ctucx) <leah@ctu.cx>
+# Maintainer: Leah (ctucx) <leah@ctu.cx>
 pkgname=oeffi-web
 pkgver=0.0.1
-pkgrel=13
+pkgrel=16
 pkgdesc="fast and simple tripplanner for the web"
 url="https://cgit.ctu.cx/oeffi-web"
 arch="all"

@@ -10,13 +10,14 @@ license="MIT"
 depends="openssl"
 makedepends="nim"
 install="$pkgname.pre-install"
-subpackages=""
-source="$pkgname.tar.gz::https://cgit.ctu.cx/oeffi-web/snapshot/oeffi-web-master.tar.gz
-        $pkgname.initd"
-builddir="$srcdir/$pkgname-master/"
+subpackages="${pkgname}-openrc"
+_commit="3363f442cf21ba1c1a6aba7f4cd571dfec8544ba"
+source="${pkgname}-${_commit}.tar.gz::https://cgit.ctu.cx/oeffi-web/snapshot/oeffi-web-${_commit}.tar.gz
+        ${pkgname}.initd"
+builddir="${srcdir}/${pkgname}-${_commit}/"
 
 build() {
-	cd $builddir
+	cd ${builddir}
 	nim c -d:release --nimcache:$PWD src/oeffi_nojs.nim
 }
 

@@ -25,12 +26,12 @@ check() {
 }
 
 package() {
-	install -Dm755 src/oeffi_nojs $pkgdir/usr/bin/$pkgname
-	install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-	mkdir -p $pkgdir/usr/share/oeffi-web
+	install -Dm755 src/oeffi_nojs ${pkgdir}/usr/bin/${pkgname}
+	install -Dm755 ${srcdir}/$pkgname.initd ${pkgdir}/etc/init.d/${pkgname}
+	mkdir -p ${pkgdir}/usr/share/oeffi-web
 	cp -r assets ${pkgdir}/usr/share/oeffi-web
 	cp -r templates ${pkgdir}/usr/share/oeffi-web
 }
 
-sha512sums="8e03a7646871444966bd686ca559a8e55d50f1d75fcd66637feb9021722d348fa2bff4e652d9722f3796cdaf5195ff13f0a3e6896b3851a89e78d385750fb0c2  oeffi-web.tar.gz
+sha512sums="ae874958ae4d9a1e3b6435519e2265b3018615be05f3dda52bae698d3dad9ca7707ec951880006f3a8e77186463dca209dc409143eccb55b3d2e304d9cbaca29  oeffi-web-3363f442cf21ba1c1a6aba7f4cd571dfec8544ba.tar.gz
 a7c5f4509c3fcf52ff514604a42030fbab230db6ca7903e3f74b523331489dfa5401631952bb8705aa281e084bcd61f6cc5fc79b82bc422ebdc487901d44e426  oeffi-web.initd"