ctucx.git: alpine-pkgs

My personal alpine-packages [deprecated in favor of nixos]

commit b7917b52bab2c754d1aab4eb395fba9b05efbf75
parent bac665e24c864ce3558860cb71e6504db88073fc
Author: alpine repo <alpine-repo@ctu.cx>
Date: Sat, 27 Nov 2021 22:09:58 +0100

oeffisearch: update version
1 file changed, 6 insertions(+), 6 deletions(-)
M
oeffisearch/APKBUILD
|
12
++++++------
diff --git a/oeffisearch/APKBUILD b/oeffisearch/APKBUILD
@@ -2,23 +2,23 @@
 # Maintainer: Leah (ctucx) <leah@ctu.cx>
 pkgname=oeffisearch
 pkgver=0.0.1
-pkgrel=15
+pkgrel=17
 pkgdesc="fast and simple tripplanner for the web"
 url="https://cgit.ctu.cx/fritzbox-exporter"
 arch="all"
 license="MIT"
 depends="openssl"
-makedepends="nim"
+makedepends="nim nimble"
 install="$pkgname.pre-install"
 subpackages="${pkgname}-openrc"
-_commit="4fc48f9a9218421a6b765499512764d4fcb86086"
+_commit="92cc53bb3a14b09ac9242e46bf138e3a1e6a72a7"
 source="${pkgname}-${_commit}.tar.gz::https://cgit.ctu.cx/oeffisearch/snapshot/oeffisearch-${_commit}.tar.gz
         ${pkgname}.initd"
 builddir="${srcdir}/${pkgname}-${_commit}/"
 
 build() {
 	cd ${builddir}
-	nim c -d:release --nimcache:$PWD src/oeffisearch.nim
+	nimble build
 }
 
 check() {

@@ -26,11 +26,11 @@ check() {
 }
 
 package() {
-	install -Dm755 src/${pkgname} $pkgdir/usr/bin/${pkgname}
+	install -Dm755 ${builddir}/oeffisearch $pkgdir/usr/bin/${pkgname}
 	install -Dm755 ${srcdir}/${pkgname}.initd ${pkgdir}/etc/init.d/${pkgname}
 	mkdir -p ${pkgdir}/usr/share
 	cp -r client ${pkgdir}/usr/share/oeffisearch
 }
 
-sha512sums="c0c7f2b24fa527f1b453acd8fd29f28570ca8e37c4de6d8f3fc8fef5255ec4c48b47dd20c5c19a9f22f7be67f2b5cd6ff1775ea8565e988b080d61e297270049  oeffisearch-4fc48f9a9218421a6b765499512764d4fcb86086.tar.gz
+sha512sums="eb94427dd2d39f4e373656e47957483ad53f1318c069423ebeee70bc04bd8ec87cc0e37bb2cc348c3106cb297588e864c17871688ea7c64c57b13117dae93640  oeffisearch-92cc53bb3a14b09ac9242e46bf138e3a1e6a72a7.tar.gz
 65dd12c9edb74505a9b9b48ddc91da6a62372d81b6729cd38984bcc39935a34caa790cfdfb2e56a1bee19daa57a76c979ee4e675702d881fa30c20d40579a3ef  oeffisearch.initd"