ctucx.git: alpine-pkgs

My personal alpine-packages [deprecated in favor of nixos]

commit ce0409acf81498db77df12fafd8f58091fa90ce1
parent 73cea2d79f1db6a8623fd5951f0362c466b33229
Author: Leah (ctucx) <leah@ctu.cx>
Date: Sat, 23 Jan 2021 16:16:46 +0100

schildichat-web: add new package
1 file changed, 28 insertions(+), 0 deletions(-)
A
schildichat-web/APKBUILD
|
28
++++++++++++++++++++++++++++
diff --git a/schildichat-web/APKBUILD b/schildichat-web/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leah (ctucx) <leah@ctu.cx>
+# Maintainer: Leah (ctucx) <leah@ctu.cx>
+pkgname=schildichat-web
+pkgver=1.7.17
+pkgrel=1
+pkgdesc="SchildiChat is a Matrix client based on Element with a more traditional instant messaging experience."
+url="https://schildi.chat/"
+arch="noarch"
+options="!check"
+license="Apache-2.0"
+source="https://github.com/SchildiChat/schildichat-desktop/releases/download/v$pkgver-sc1/schildichat-web-$pkgver-sc1.tar.gz"
+builddir="$srcdir/schildichat-web-$pkgver-sc1"
+
+build() {
+	return 0
+}
+
+package() {
+	mkdir -p "$pkgdir"/usr/share/webapps \
+		"$pkgdir"/etc/schildichat-web
+	cp -r "$builddir" "$pkgdir"/usr/share/webapps/schildichat-web
+	mv "$pkgdir"/usr/share/webapps/schildichat-web/config.sample.json \
+		"$pkgdir"/etc/schildichat-web
+	ln -sf /etc/schildichat-web/config.json \
+		"$pkgdir"/usr/share/webapps/schildichat-web/config.json
+}
+
+sha512sums="5c30d3184cf8a26e8f649185493da8cac7642a997c5a4bf157aa1ce35533638c0e85467a8a21c187fbcf7993ee219cba9e8df4a56b4faffe2ef143b6839377fe  schildichat-web-1.7.17-sc1.tar.gz"