ctucx.git: alpine-pkgs

My personal alpine-packages [deprecated in favor of nixos]

commit e51f8dd05d1a056effea7d01bda53f1179d4f45c
parent d4dc3d62157590e6e619fed8315ffa4352b119f4
Author: Leah (ctucx) <leah@ctu.cx>
Date: Sun, 14 Mar 2021 15:47:42 +0100

oeffi-web: update to commit 47d021f1ae815a71325d8ee73da72383973bd571
1 file changed, 7 insertions(+), 8 deletions(-)
M
oeffi-web/APKBUILD
|
15
+++++++--------
diff --git a/oeffi-web/APKBUILD b/oeffi-web/APKBUILD
@@ -2,33 +2,32 @@
 # Maintainer: Leah (ctucx) <leah@ctu.cx>
 pkgname=oeffi-web
 pkgver=0.0.1
-pkgrel=25
+pkgrel=26
 pkgdesc="fast and simple tripplanner for the web"
 url="https://cgit.ctu.cx/oeffi-web"
 arch="all"
 license="MIT"
 depends="openssl"
-makedepends="nim"
+makedepends="nim nimble"
 options="!check"
 install="$pkgname.pre-install"
 subpackages="${pkgname}-openrc"
-_commit="72bca49014503a60e3e1ab7994d38eb9870a9ced"
+_commit="47d021f1ae815a71325d8ee73da72383973bd571"
 source="${pkgname}-${_commit}.tar.gz::https://cgit.ctu.cx/${pkgname}/snapshot/${pkgname}-${_commit}.tar.gz
         ${pkgname}.initd"
 builddir="${srcdir}/${pkgname}-${_commit}/"
 
 build() {
 	cd ${builddir}
-	nim c -d:release --nimcache:$PWD src/oeffi.nim
+	nimble build -y -d:release
 }
 
 package() {
-	install -Dm755 src/oeffi ${pkgdir}/usr/bin/${pkgname}
+	install -Dm755 ${builddir}/oeffi ${pkgdir}/usr/bin/${pkgname}
 	install -Dm755 ${srcdir}/$pkgname.initd ${pkgdir}/etc/init.d/${pkgname}
 	mkdir -p ${pkgdir}/usr/share/oeffi-web
-	cp -r assets ${pkgdir}/usr/share/oeffi-web
-	cp -r templates ${pkgdir}/usr/share/oeffi-web
+	cp -r ${builddir}/src/assets/* ${pkgdir}/usr/share/oeffi-web
 }
 
-sha512sums="c95ea1e8e5fc78cbaa26b8e71122dac01a462f5d3599ad42eeebc67683cd7941d70cf8506af274f994f3cf575c22ca1ac02ee6f25c8500fa2a073cbe210ed449  oeffi-web-72bca49014503a60e3e1ab7994d38eb9870a9ced.tar.gz
+sha512sums="b84f533f5feaf71ad11920009736e7f4bdd7f0839983f9aca6035c6c4cf25a0092c1c2b1df286e2eff3ed3673f62c31046bcfd5d24e545d320e894fb3e9d4a2a  oeffi-web-47d021f1ae815a71325d8ee73da72383973bd571.tar.gz
 a7c5f4509c3fcf52ff514604a42030fbab230db6ca7903e3f74b523331489dfa5401631952bb8705aa281e084bcd61f6cc5fc79b82bc422ebdc487901d44e426  oeffi-web.initd"