ctucx.git: aur-packages

My personal aur-packages [deprecated in favor of nixos]

commit e4478e97b78341ad56e2a1c9f6682f747b89f610
parent 3c950d93f59ad9db8c5c5ff9b55efaf864df8af6
Author: ctucx <c@ctu.cx>
Date: Wed, 3 Feb 2021 11:42:28 +0100

initial commit
2 files changed, 41 insertions(+), 0 deletions(-)
A
smartie-pwa/.SRCINFO
|
14
++++++++++++++
A
smartie-pwa/PKGBUILD
|
27
+++++++++++++++++++++++++++
diff --git a/smartie-pwa/.SRCINFO b/smartie-pwa/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = smartie-pwa
+	pkgver = 0.1
+	pkgrel = 1
+	url = https://cgit.ctu.cx/smartie-pwa/
+	arch = x86_64
+	license = GPL-3
+	makedepends = yarn
+	makedepends = git
+	depends = glibc
+	source = smartie-pwa-8eb18cf941fb850b36c7dc586907837bee2fccc9.tar.gz::https://cgit.ctu.cx/smartie-pwa/snapshot/smartie-pwa-8eb18cf941fb850b36c7dc586907837bee2fccc9.tar.gz
+	sha256sums = cf4b091199f0b420baa86563af1112890cf15fc807d6e57cd23c1893612456d6
+
+pkgname = smartie-pwa
+
diff --git a/smartie-pwa/PKGBUILD b/smartie-pwa/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=smartie-pwa
+pkgver=0.1
+pkgrel=1
+arch=('x86_64')
+url="https://cgit.ctu.cx/${pkgname}/"
+license=( 'GPL-3' )
+depends=( 'glibc' )
+makedepends=( 'yarn' 'git' )
+_commit="8eb18cf941fb850b36c7dc586907837bee2fccc9"
+source=("${pkgname}-${_commit}.tar.gz::https://cgit.ctu.cx/${pkgname}/snapshot/${pkgname}-${_commit}.tar.gz")
+sha256sums=('cf4b091199f0b420baa86563af1112890cf15fc807d6e57cd23c1893612456d6')
+
+build() {
+  cd "$srcdir/${pkgname}-${_commit}/"
+  yarn install
+  ./node_modules/rollup/dist/bin/rollup -c
+}
+
+package() {
+  cd "$srcdir/${pkgname}-${_commit}"
+  install -dm755  "$pkgdir"/usr/share/webapps/smartie-pwa/
+  install -Dm755 ./index.html           "$pkgdir"/usr/share/webapps/smartie-pwa/
+  install -Dm755 ./main.min.js          "$pkgdir"/usr/share/webapps/smartie-pwa/
+  install -Dm755 ./sw.js                "$pkgdir"/usr/share/webapps/smartie-pwa/
+  install -Dm755 ./manifest.json        "$pkgdir"/usr/share/webapps/smartie-pwa/
+  install -Dm755 ./favicon-512x512.png  "$pkgdir"/usr/share/webapps/smartie-pwa/
+}